UI Mis-Functions...Conflicts?

Started by RonB, December 10, 2010, 01:50:16 pm

Previous topic - Next topic

RonB

December 10, 2010, 01:50:16 pm Last Edit: December 10, 2010, 05:07:32 pm by RonB
Hi,
Using the free version.
Found while doing a tut with a Fractal terrain...Tweak Noise tab...Noise flavour there are no choices, only Perlin mix 1.
Also none of the other drop downs work, such as Variation method etc.

The tabs, Scale, Colour, Displacement etc. do not function correctly.
I have to click on the tab to the right of the one I want and often that does not work.

I am thinking there must be a conflict going on with something in my system but could not find a "known conflicts list" anywhere on the site.
I did searches on the forum but found no threads regarding the issue I am having...

Running on Win XP 64 bit Xeon 3.0 dual quad core 6 gig ram.
GeForce GTS 250...CUDA installed.

Any ideas?

Any and all comments and suggestions very much appreciated...Thanks!

RonB

Henry Blewer

Try disabling one of the two CPU cores. Let us know if that works.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Tangled-Universe

Do you use an alternative windows-theme?
Do you have the latest graphic card drivers installed?

Martin

Henry Blewer

I think it might be a core scaling problem. If he can get the menus and things to work on one CPU, then he can get to the preferences. I think the program is detecting all the cores. If he changes the number of cores to use in preferences, it will probably fix the problem. I would start with 4 cores and work up.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

RonB

Hi Guys,

Thanks for your help...I really appreciate it.

I set # of cores in prefs from 1 on up to 8...no diff.
Set the boot ini to start & run with 1 core...no diff.
Tried setting the prog's Affinity in Task Manager from 1 to 7 cores...no diff.

Don't know what to look at next...must be something simple...it usually is.

RonB

Kadri

December 10, 2010, 06:38:50 pm #5 Last Edit: December 10, 2010, 06:41:19 pm by Kadri
Uninstall and reinstall TG2 (i think you tried this already).

Do you have an alternate windows theme as Martin asked?
Did you change the windows system font and-or size?
Try the default one (revert any change to default , related to fonts).

Is your system overclocked?

Update any drivers you have. Especially graphics drivers.

What changed in the near time in your system?
Go back to an old System Restore Point .





Henry Blewer

I think Cypher runs a duel CPU machine. He may have an idea. I am stumped.

Martin's ideas about the graphics card might be the next place to look. I would try disabling CUDA also.

The other thing which occurs to me is using Windows XP 64. I upgraded to Windows 7 64. I also used the 32 bit version of Vista without problems.

Run a System report and save a copy. I think Planetside will want this to diagnose this problem.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Tangled-Universe

I don't see why threading or CUDA would have to do about this.
It's a display error by windows, likely.
As far as I know the (multi-)threading doesn't bother about this, nor does CUDA draw your on-screen graphics.

Therefore I think Ron uses a windows theme which is incompatible with the UI instruction set TG2 uses, or that his graphics drivers aren't updated (or conflicting somehow).

RonB

December 10, 2010, 08:29:40 pm #8 Last Edit: December 10, 2010, 08:31:45 pm by RonB
Again...Thank you!

No...my system is not over-clocked.
I did have the classic theme on and reverted back to the XP theme and the tabs now function properly but the various Noise types or other drop downs are still not working.
I did update the vid drivers not long ago but will do that again just to make sure.
Nothing really different with the system that changed before loading Terragen.

However I got encouraged reverting the theme and see the improvement in the tabs.
I think it's getting closer...I'm feeling it has to do with the vid drivers somehow...

Cheers,
Ron

Tangled-Universe

Ah right, we're getting there slowly :)
What does work with the classic theme and what doesn't?
Please let us know as well how the driver update works out.

Martin

RonB

O.K. vid card drivers updated but did not change the problem...

Also dumped a bunch of progs just for good measure...nothing changed.

I did notice I have a bunch of leftovers etc. showing up in Add or Remove that are no longer there and no way to get them out.
It's been a couple years since a complete re-format and system install...I imagine the registry is not in the best of shape.
I am reluctant to use a reg cleaner though as I have read one shouldn't.

Probably what I need to do is backup all my favs, bookmarks, passwords etc and clean the machine and maybe even go to win 7.
Hate to cause other than this all my other 3D apps run fine with no problems at all.

errgh...

Henry Blewer

Try out IObit's Advanced System Care. I use it often, but it does not like Steam and visa versa. The free version will let you know how the registry looks. It will also tweak your system if you like.

The full version is about $20 for a year subscription.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

jo

Hi,

I'm not sure what might be causing this problem other than something like theming software which others have suggested. There must be something unusual about your configuration because these are not problems typically experienced. I personally haven't tested on XP 64 but I'm sure there are others using it and I haven't heard of problems.

Once thing I can say with 99.5% confidence is that it won't be anything to do with the number of cores. All the number of cores/threads settings in TG2 currently only effect rendering and have nothing to do with the UI.

Regards,

Jo

RonB

December 11, 2010, 12:17:19 am #13 Last Edit: December 11, 2010, 02:22:06 am by RonB
Thanks Jo...yes, it is strange and who knows at this point anyone's guess is as good as mine.

I'll try the System Care njeneb, couldn't hurt...thanks.
I'll let you all know what happens.
(Nothing happened).

Well, looks like I exhausted all your ideas as well as the few I had.
Think I am going to put Terragen on the back burner until I get this machine cleaned out reformatted and possibly upgraded to Win 7.

Thanks to everyone!

Cheers,
RonB

cyphyr

December 11, 2010, 05:22:52 am #14 Last Edit: December 11, 2010, 05:25:40 am by cyphyr
Quote from: njeneb on December 10, 2010, 06:41:43 pm
I think Cypher runs a duel CPU machine. He may have an idea. I am stumped.
....


If only !! LOL
Sounds like a graphic card issue to me, have you had any similar issues with other programs?
Richard

ps: have you tried with CUDA disabled?
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)