vertical line in 360 HDRI

Started by yaschan, July 24, 2020, 10:08:48 pm

Previous topic - Next topic

yaschan

I am on Windows build 4.4.67 and getting this white line in HDRI when rendering with spherical camera and saving out as .exr. Never happened before.
What am I doing wrong?

WAS

This happens with the water shader as well. I think it's as seam of the planet/plane?

If you try putting your camera offsetted from 0,0,0 does it go away looking at that area from another angle?

yaschan

Yes my camera is offset from 0,0,0. This also happens with custom heightmaps loaded from other apps.
Indeed, the pixels that "bleed" in the gap are the color of the atmosphere, and it is worth noting that this does not appear in atmosphere.
Nothing a good clonebrush can't fix in Photoshop but this haven't happened in earlier versions. Using the latest one now.

yaschan

Rather than landscape having a gap the seam only appears on the area where the HDRI wraps around it seems. This is what I am getting. Again I am exporting in .EXR.

Can image reconstruction filter have impact on this? I am in the process of testing each of them.



yaschan

Changing to non-recommended Box the issue is less prominent but still there


WAS

March 11, 2021, 12:37:57 am #5 Last Edit: March 11, 2021, 12:51:51 am by WAS
Just a hunch, as I can't reproduce this effect to test, try playing with these three settings (independently).

I assume low light is exposing glowing haze from below the surface of the planet.

yaschan

I tried all of them. Unfortunately none of them really make a difference. Maybe I should send the project file? This seems to appear in most of my environments.

WAS

Yeah you can send the project file to support [at] planetside.co.uk and Kevin or Matt will take a look at it. You can also simplify the scene and upload here and we can take a look at it, which may be faster (no offense PS).

yaschan

This also happens with no terrain present in the scene.

WAS

Have you made adjustments to the background sphere?

Kadri

Quote from: yaschan on March 16, 2021, 06:58:29 pmThis also happens with no terrain present in the scene.
Then if there is nothing in the scene just post the TGD file here to have a look at. Could be faster to get help.

SuddenPlanet

March 17, 2021, 01:00:33 am #11 Last Edit: March 17, 2021, 01:04:41 am by SuddenPlanet
I have had this happen before too, but don't remember the fix.

Try this though if you get a chance.  Increase Micropoly detail to .8 or even 1 and see if the seam goes away.

Also try increasing your GI settings to see if there is any effect.  Try 3, 3, 8 or 4, 4, 16 (Default is 2, 2, 8).

Also does the seam happen at all resolutions?  Try rendering 4000x2000 or 8000x4000 and see if the seam is there.

If you have a test scene share it here and I'll test it on my machine.

EDIT:  I did find this in the Docs:
"GI prepass padding: This specifes how much to enlarge the area of image calculated during the prepass, which may be useful to avoid mismatched lighting between adjacent cropped renders or pieces of a panorama when not using GI cache files (GI cache files effectively solve this problem). A value of 0 means no padding. A value of 1 adds a border to each side of the frustum which is equivalent to the width or height of the image or crop region, which makes the frustum 3 times as wide and 3 times as tall. Negative values shrink the area/frustum instead of enlarging it."

Anyways, I seem to remember it had something do do with some of these settings.

Derek

yaschan

The error happens in every scene. No I have not made any changes to background sphere.

This is literally the startup scene with only settings changed being camera to spherical.

As you can see the vertical stripe appears in the HDRI if you render it and save as 32bit.


yaschan

Yes, could be same. That post is from 2013. Will there be a fix for this in future?
With single images this isn't a show stopper, I could even make automatic photoshop tool to fix these.