Fractal procedural erosion shader public beta

Started by blinkfrog, November 15, 2015, 01:49:40 pm

Previous topic - Next topic

Shigawire

December 14, 2015, 01:03:26 pm #75 Last Edit: December 14, 2015, 01:06:10 pm by Shigawire
Quote from: blinkfrog on December 14, 2015, 03:14:25 am
Quote from: Dune on December 14, 2015, 03:05:54 am
No difference between final and position in texture? Surface shader may need a compute before it works properly (like blue node 'get...').

Well, surface shader preview displays correct mask.
You can check test tgd.


Indeed. I also tried the Compute Normal before I did my tests yesterday. I opened your file, and indeed it previews the Surface Layer correctly with the correct slopes selected. It just doesn't affect the Erosion.

To preview the masking of altitude constraint, the Compute Normal must be replaced by a Compute Terrain node, then the preview works.
The masking still doesn't work on the Erosion of course.

Oh well, it's a beta.. and it's an amazing one at that! I'm sure you'll find a way.

mdharrington

My earlier comments about it being slow were a bit overstated....

was working on my laptop....16 gigs quad core....and it was slow

On my desktop it is at least 8-10 times faster...so a 1.5 minute wait before a render as opposed to 14 minute wait....

Not sure why it is so much faster....250% more processing power and 24 gigs vs 16, you would think it would only be double or triple the speed

sarwanov


blinkfrog

Here is a new version, 0.4.0.1 with some bugfixes (masking by Surface Layer still not fixed).
Also this is important update because previous version will expire on Jan 01, 2016 (I forgot do remove this from previous beta). New beta has no expiration date.

Daniil.

Dune


AP

December 20, 2015, 05:01:54 am #80 Last Edit: December 20, 2015, 06:22:28 am by Chris
Thank you.

Shigawire


mhaze



AndyWelder

"Ik rotzooi maar wat aan" Karel Appel


blinkfrog

About bugfixes in last version: discontinuity bug that Chris found should be fixed; shader now should not block color output of previous shaders; some minor bugs, that I don't remember.

AP


rajm

Thanks! Is that just an update for the 64 bit version? The 32 bit one has the same size and date as the previous one.

(I've got machines of both flavours)

blinkfrog

Quote from: rajm on December 30, 2015, 11:00:33 am
Thanks! Is that just an update for the 64 bit version? The 32 bit one has the same size and date as the previous one.

Thanks! This is my fault, here is fixed zip: